using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^//\w+\s+JOB\h*(?:[^\s=]+)?(?:,|$)|\G(?!^))(?:\w+=\w+)?";
string input = @"//jobname JOB
//jobname JOBAccountInfo,'PGMRname',keyword=param,keyword=param,keywod=param
//jobname JOB ,keyword=param,keyword=param
//jobname JOB (Accountinfo)
//jobname JOB 'pgmrname'
//jobname JOB accountinfo";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}