import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^//\\w+\\s+JOB\\h*(?:[^\\s=]+)?(?:,|$)|\\G(?!^))(?:\\w+=\\w+)?";
final String string = "//jobname JOB \n"
+ "//jobname JOBAccountInfo,'PGMRname',keyword=param,keyword=param,keywod=param\n\n"
+ "//jobname JOB ,keyword=param,keyword=param\n\n"
+ "//jobname JOB (Accountinfo)\n\n"
+ "//jobname JOB 'pgmrname'\n\n"
+ "//jobname JOB accountinfo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}