$re = '~(?:^//\w+\s+JOB\h*(?:[^\s=]+)?(?:,|$)|\G(?!^))(?:\w+=\w+)?~ms';
$str = '//jobname JOB
//jobname JOBAccountInfo,\'PGMRname\',keyword=param,keyword=param,keywod=param
//jobname JOB ,keyword=param,keyword=param
//jobname JOB (Accountinfo)
//jobname JOB \'pgmrname\'
//jobname JOB accountinfo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);