re = /(?:^\/\/\w+\s+JOB\h*(?:[^\s=]+)?(?:,|$)|\G(?!^))(?:\w+=\w+)?/m
str = '//jobname JOB
//jobname JOBAccountInfo,\'PGMRname\',keyword=param,keyword=param,keywod=param
//jobname JOB ,keyword=param,keyword=param
//jobname JOB (Accountinfo)
//jobname JOB \'pgmrname\'
//jobname JOB accountinfo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end