#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!(?:name|city|(?<=nu)mber)\(|\[)(["'])[^)\]]+?(?<!\\)\1"
Local $sString = "("h") ["hi"] {"hi"}" & @CRLF & _
"a("hI") " & @CRLF & _
"j("hi")" & @CRLF & _
"j('hi')" & @CRLF & _
"name("hi")" & @CRLF & _
"name('hi')" & @CRLF & _
"n("hi")" & @CRLF & _
"city('hi')" & @CRLF & _
"number('hi')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")