$re = '/(?<!(?:name|city|(?<=nu)mber)\(|\[)(["\'])[^)\]]+?(?<!\\\\)\1/';
$str = '("h") ["hi"] {"hi"}
a("hI")
j("hi")
j(\'hi\')
name("hi")
name(\'hi\')
n("hi")
city(\'hi\')
number(\'hi\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);