re = /(?<!(?:name|city|(?<=nu)mber)\(|\[)(["'])[^)\]]+?(?<!\\)\1/
str = '("h") ["hi"] {"hi"}
a("hI")
j("hi")
j(\'hi\')
name("hi")
name(\'hi\')
n("hi")
city(\'hi\')
number(\'hi\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end