import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!(?:name|city|(?<=nu)mber)\\(|\\[)([\"'])[^)\\]]+?(?<!\\\\)\\1";
final String string = "(\"h\") [\"hi\"] {\"hi\"}\n"
+ "a(\"hI\") \n"
+ "j(\"hi\")\n"
+ "j('hi')\n"
+ "name(\"hi\")\n"
+ "name('hi')\n"
+ "n(\"hi\")\n"
+ "city('hi')\n"
+ "number('hi')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}