#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+\.)*\d+$"
Local $sString = "20" & @CRLF & _
"26" & @CRLF & _
"91.02" & @CRLF & _
"90.01.1" & @CRLF & _
"99.55.55.55.10.22.00" & @CRLF & _
"" & @CRLF & _
"sdf 654" & @CRLF & _
"654" & @CRLF & _
"654.654 dfg" & @CRLF & _
"654 " & @CRLF & _
"ffff.gg.546" & @CRLF & _
"dfg.54" & @CRLF & _
"654.654.654." & @CRLF & _
".1.2" & @CRLF & _
"1.11.111.1111.1111111111111111111111111111.111111111111111111111111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")