package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+\.)*\d+$`)
var str = `20
26
91.02
90.01.1
99.55.55.55.10.22.00
sdf 654
654
654.654 dfg
654
ffff.gg.546
dfg.54
654.654.654.
.1.2
1.11.111.1111.1111111111111111111111111111.111111111111111111111111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}