# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\d+\.)*\d+$"
test_str = ("20\n"
"26\n"
"91.02\n"
"90.01.1\n"
"99.55.55.55.10.22.00\n\n"
"sdf 654\n"
"654\n"
"654.654 dfg\n"
"654 \n"
"ffff.gg.546\n"
"dfg.54\n"
"654.654.654.\n"
".1.2\n"
"1.11.111.1111.1111111111111111111111111111.111111111111111111111111111")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.