$re = '/^(?:\d+\.)*\d+$/m';
$str = '20
26
91.02
90.01.1
99.55.55.55.10.22.00
sdf 654
654
654.654 dfg
654
ffff.gg.546
dfg.54
654.654.654.
.1.2
1.11.111.1111.1111111111111111111111111111.111111111111111111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);