import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.)(?:\\n?[A-Z]+(?:_[A-Z]+)*)+$";
final String string = "ERIS_TEST_GROUP_NAME\n"
+ "JENNIFER_AD_GROUP_NAME\n"
+ "PSEUDO_TEST_TEAM\n"
+ "TEST_GROUP\n"
+ "TEST";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}