const regex = /^(?=.)(?:\n?[A-Z]+(?:_[A-Z]+)*)+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.)(?:\\n?[A-Z]+(?:_[A-Z]+)*)+$', '')
const str = `ERIS_TEST_GROUP_NAME
JENNIFER_AD_GROUP_NAME
PSEUDO_TEST_TEAM
TEST_GROUP
TEST`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}