$re = '/^(?=.)(?:\n?[A-Z]+(?:_[A-Z]+)*)+$/';
$str = 'ERIS_TEST_GROUP_NAME
JENNIFER_AD_GROUP_NAME
PSEUDO_TEST_TEAM
TEST_GROUP
TEST';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);