import re
regex = re.compile(r"^(?=.)(?:\n?[A-Z]+(?:_[A-Z]+)*)+$")
test_str = ("ERIS_TEST_GROUP_NAME\n"
"JENNIFER_AD_GROUP_NAME\n"
"PSEUDO_TEST_TEAM\n"
"TEST_GROUP\n"
"TEST")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")