#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\/\*\*[\s\S]*\*\/)"
Local $sString = "/**" & @CRLF & _
"* Places given shatter objects images into the specified dom element" & @CRLF & _
"*" & @CRLF & _
"* @param {object} shatter - Shatter object" & @CRLF & _
"* @param {object} domElement - The dom element to append images to" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"function placeShatter (shatter, domElement) {" & @CRLF & _
" // adjustment to center image on screen" & @CRLF & _
" var adjustment = (window.innerWidth / 2) * image.width / 2;" & @CRLF & _
" for (var i = 0; i < shatter.images.length; i++) {" & @CRLF & _
" placeImageAbsolute(shatter.images[i].image," & @CRLF & _
" domElement, " & @CRLF & _
" shatter.images[i].x, " & @CRLF & _
" shatter.images[i].y," & @CRLF & _
" adjustment," & @CRLF & _
" YLOC);" & @CRLF & _
" } " & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")