using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*\*[\s\S]*\*\/)";
string input = @"/**
* Places given shatter objects images into the specified dom element
*
* @param {object} shatter - Shatter object
* @param {object} domElement - The dom element to append images to
*/
function placeShatter (shatter, domElement) {
// adjustment to center image on screen
var adjustment = (window.innerWidth / 2) * image.width / 2;
for (var i = 0; i < shatter.images.length; i++) {
placeImageAbsolute(shatter.images[i].image,
domElement,
shatter.images[i].x,
shatter.images[i].y,
adjustment,
YLOC);
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}