import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\*\\*[\\s\\S]*\\*\\/)";
final String string = "/**\n"
+ "* Places given shatter objects images into the specified dom element\n"
+ "*\n"
+ "* @param {object} shatter - Shatter object\n"
+ "* @param {object} domElement - The dom element to append images to\n"
+ "*/\n\n"
+ "function placeShatter (shatter, domElement) {\n"
+ " // adjustment to center image on screen\n"
+ " var adjustment = (window.innerWidth / 2) * image.width / 2;\n"
+ " for (var i = 0; i < shatter.images.length; i++) {\n"
+ " placeImageAbsolute(shatter.images[i].image,\n"
+ " domElement, \n"
+ " shatter.images[i].x, \n"
+ " shatter.images[i].y,\n"
+ " adjustment,\n"
+ " YLOC);\n"
+ " } \n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}