// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\/\*\*[\s\S]*\*\/)").unwrap();
let string = "/**
* Places given shatter objects images into the specified dom element
*
* @param {object} shatter - Shatter object
* @param {object} domElement - The dom element to append images to
*/
function placeShatter (shatter, domElement) {
// adjustment to center image on screen
var adjustment = (window.innerWidth / 2) * image.width / 2;
for (var i = 0; i < shatter.images.length; i++) {
placeImageAbsolute(shatter.images[i].image,
domElement,
shatter.images[i].x,
shatter.images[i].y,
adjustment,
YLOC);
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}