const regex = /^(?:(?:(?!\bword\b).)*\bword\b){3}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?!\\bword\\b).)*\\bword\\b){3}', '')
const str = `zero word one word two word three word four word five word six`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}