re = /^(?:(?:(?!\bword\b).)*\bword\b){3}/
str = 'zero word one word two word three word four word five word six'
# Print the match result
str.match(re) do |match|
puts match.to_s
end