$re = '/^(?:(?:(?!\bword\b).)*\bword\b){3}/';
$str = 'zero word one word two word three word four word five word six';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);