import Foundation
let pattern = #"^(?:(?:(?!\bword\b).)*\bword\b){3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"zero word one word two word three word four word five word six"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}