#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)99_\w{3}_(A|B)_((X|(?>YZ))(0*[1-9][0-9]?)_(FOO|BAR) \3Y?-(\b0?20(1[4-9]|[2-9][0-9])\b)-\b0?((?:[1-9]|1[0-2])|(?:[4]|1[0]))\b$)"
Local $sString = "99_GOG_A_X1_FOO X-2014-09" & @CRLF & _
"99_YAK_A_YZ1_BAR YZY-2014-10" & @CRLF & _
"99_YAK_A_YZ1_BAR YZY-2014-11" & @CRLF & _
"99_GOG_A_X1_FOO X-2014-13" & @CRLF & _
"99_YAK_A_X1_BAR YZY-2014-10" & @CRLF & _
"99_GOG_A_YZ1_FOO X-2014-10" & @CRLF & _
"99_GOG_A_X1_FOO X-2014-11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")