re = /99_\w{3}_(A|B)_((X|(?>YZ))(0*[1-9][0-9]?)_(FOO|BAR) \3Y?-(\b0?20(1[4-9]|[2-9][0-9])\b)-\b0?((?:[1-9]|1[0-2])|(?:[4]|1[0]))\b$)/m
str = '99_GOG_A_X1_FOO X-2014-09
99_YAK_A_YZ1_BAR YZY-2014-10
99_YAK_A_YZ1_BAR YZY-2014-11
99_GOG_A_X1_FOO X-2014-13
99_YAK_A_X1_BAR YZY-2014-10
99_GOG_A_YZ1_FOO X-2014-10
99_GOG_A_X1_FOO X-2014-11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end