import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "99_\\w{3}_(A|B)_((X|(?>YZ))(0*[1-9][0-9]?)_(FOO|BAR) \\3Y?-(\\b0?20(1[4-9]|[2-9][0-9])\\b)-\\b0?((?:[1-9]|1[0-2])|(?:[4]|1[0]))\\b$)";
final String string = "99_GOG_A_X1_FOO X-2014-09\n"
+ "99_YAK_A_YZ1_BAR YZY-2014-10\n"
+ "99_YAK_A_YZ1_BAR YZY-2014-11\n"
+ "99_GOG_A_X1_FOO X-2014-13\n"
+ "99_YAK_A_X1_BAR YZY-2014-10\n"
+ "99_GOG_A_YZ1_FOO X-2014-10\n"
+ "99_GOG_A_X1_FOO X-2014-11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}