using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"99_\w{3}_(A|B)_((X|(?>YZ))(0*[1-9][0-9]?)_(FOO|BAR) \3Y?-(\b0?20(1[4-9]|[2-9][0-9])\b)-\b0?((?:[1-9]|1[0-2])|(?:[4]|1[0]))\b$)";
string input = @"99_GOG_A_X1_FOO X-2014-09
99_YAK_A_YZ1_BAR YZY-2014-10
99_YAK_A_YZ1_BAR YZY-2014-11
99_GOG_A_X1_FOO X-2014-13
99_YAK_A_X1_BAR YZY-2014-10
99_GOG_A_YZ1_FOO X-2014-10
99_GOG_A_X1_FOO X-2014-11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}