package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https://(?:demo|test)\.site1\.mybrand\.company/\S*$`)
var str = `https://demo.site1.mybrand.company/
https://test.site1.mybrand.company/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}