re = /^https:\/\/(?:demo|test)\.site1\.mybrand\.company\/\S*$/m
str = 'https://demo.site1.mybrand.company/
https://test.site1.mybrand.company/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end