$re = '`^https://(?:demo|test)\.site1\.mybrand\.company/\S*$`m';
$str = 'https://demo.site1.mybrand.company/
https://test.site1.mybrand.company/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);