const regex = /^stop.*/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^stop.*', 's')
const str = `stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}