$re = '/^stop.*/s';
$str = 'stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);