package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)-\d+\..*`)
var str = `deneme-150-bin-midye-satildi-1987.html`
var substitution = "$1/"
fmt.Println(re.ReplaceAllString(str, substitution))
}