import Foundation
let pattern = #"(.*?)-\d+\..*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"deneme-150-bin-midye-satildi-1987.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)