const regex = /(.*?)-\d+\..*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)-\\d+\\..*', 'gm')
const str = `deneme-150-bin-midye-satildi-1987.html`;
const subst = `$1/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);