re = /(.*?)-\d+\..*/m
str = 'deneme-150-bin-midye-satildi-1987.html'
subst = '$1/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result