import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1\\.([^\\r\\n]+\\r\\n)(.*?)^4\\.([^\\r\\n]+\\r\\n)";
final String string = "N06\n\n\n"
+ "Какое общее название в соответствии с Правилами по обеспечению промышленной безопасности грузоподъемных кранов имеют грузозахватные органы грузоподъемных кранов и грузозахватные приспособления:\n"
+ " 1. такелажная оснастка\n"
+ " 2. приспособления для грузоподъемных операций;\n"
+ " 3. захваты;\n"
+ "4. приспособления для грузоподъемных операций;\n"
+ "N07\n\n\n"
+ "При эксплуатации кранов мостового типа должна применяться марочная система, при которой управление грузоподъемным краном разрешается машинисту крана (крановщику),:\n"
+ " 1. ознакомленному под роспись с порядком применения ключ-марки;\n"
+ " 2. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;\n"
+ " 3. выполняющему работы по наряду-допуску\n"
+ "4. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;\n";
final String subst = "1.\\3\\24.\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}