import Foundation
let pattern = #"^1\.([^\r\n]+\r\n)(.*?)^4\.([^\r\n]+\r\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
N06
Какое общее название в соответствии с Правилами по обеспечению промышленной безопасности грузоподъемных кранов имеют грузозахватные органы грузоподъемных кранов и грузозахватные приспособления:
1. такелажная оснастка
2. приспособления для грузоподъемных операций;
3. захваты;
4. приспособления для грузоподъемных операций;
N07
При эксплуатации кранов мостового типа должна применяться марочная система, при которой управление грузоподъемным краном разрешается машинисту крана (крановщику),:
1. ознакомленному под роспись с порядком применения ключ-марки;
2. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
3. выполняющему работы по наряду-допуску
4. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1.\3\24.\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)