use strict;
my $str = 'N06
Какое общее название в соответствии с Правилами по обеспечению промышленной безопасности грузоподъемных кранов имеют грузозахватные органы грузоподъемных кранов и грузозахватные приспособления:
1. такелажная оснастка
2. приспособления для грузоподъемных операций;
3. захваты;
4. приспособления для грузоподъемных операций;
N07
При эксплуатации кранов мостового типа должна применяться марочная система, при которой управление грузоподъемным краном разрешается машинисту крана (крановщику),:
1. ознакомленному под роспись с порядком применения ключ-марки;
2. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
3. выполняющему работы по наряду-допуску
4. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
';
my $regex = qr~^1\.([^\r\n]+\r\n)(.*?)^4\.([^\r\n]+\r\n)~mp;
my $subst = '1.\\3\\24.\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";