#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<h2.*?>([0-9]+)\.\s+(.*?)</h2>"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"<h2 id="1">1. Item 1</h2>" & @CRLF & _
"<h2 id="1.2">1.2. Item 1.2</h2>" & @CRLF & _
"<h2 id="2">2. Item 2</h2>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")