// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<h2.*?>([0-9]+)\.\s+(.*?)</h2>").unwrap();
let string = "
<h2 id=\"1\">1. Item 1</h2>
<h2 id=\"1.2\">1.2. Item 1.2</h2>
<h2 id=\"2\">2. Item 2</h2>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}