import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h2.*?>([0-9]+)\\.\\s+(.*?)</h2>";
final String string = "\n\n"
+ "<h2 id=\"1\">1. Item 1</h2>\n"
+ "<h2 id=\"1.2\">1.2. Item 1.2</h2>\n"
+ "<h2 id=\"2\">2. Item 2</h2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}