using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*?\.)(.*?[1-9])(?!.*?\.)(?=0*$)|^.*$";
string substitution = @"";
string input = @"3.04000
134000
0.456000
143.5656080000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}