$re = '/(?=.*?\.)(.*?[1-9])(?!.*?\.)(?=0*$)|^.*$/m';
$str = '3.04000
134000
0.456000
143.5656080000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;