const regex = /(?=.*?\.)(.*?[1-9])(?!.*?\.)(?=0*$)|^.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*?\\.)(.*?[1-9])(?!.*?\\.)(?=0*$)|^.*$', 'gm')
const str = `3.04000
134000
0.456000
143.5656080000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);