import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*?\\.)(.*?[1-9])(?!.*?\\.)(?=0*$)|^.*$";
final String string = "3.04000\n"
+ "134000\n"
+ "0.456000\n"
+ "143.5656080000";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}