# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[A-Z](?=(?:'[^']*'|[^'\n])*$)//gm;t' <<< "SELECT column_name FROM table_name WHERE column_name IN ('A' , 'stu' ,'Meyer', ....);
SELECT column_name FROM table_name WHERE column_name IN ('A' , 'stu' ,'Meyer', 'BAR');"