const regex = /[A-Z](?=(?:'[^']*'|[^'\n])*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z](?=(?:\'[^\']*\'|[^\'\\n])*$)', 'gm')
const str = `SELECT column_name FROM table_name WHERE column_name IN ('A' , 'stu' ,'Meyer', ....);
SELECT column_name FROM table_name WHERE column_name IN ('A' , 'stu' ,'Meyer', 'BAR');`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);