import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z](?=(?:'[^']*'|[^'\\n])*$)";
final String string = "SELECT column_name FROM table_name WHERE column_name IN ('A' , 'stu' ,'Meyer', ....);\n\n"
+ "SELECT column_name FROM table_name WHERE column_name IN ('A' , 'stu' ,'Meyer', 'BAR');";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}